Qt推出Clazy框架帮助项目从Qt 5移植到Qt 6

近日,Qt 推出了 Clazy 框架,专门用于帮助项目从 Qt 5 移植到 Qt 6。该框架包含一些检查,这些检查可以使用 Clazy 作为编译器插件运行,也可以在 .json 文件上使用 Clazy standalone 或从 Qt Creator 内部运行。下面是专用于 Qt 6 移植的 Clazy 检查列表:

qt6-deprecated-api-fixes。Qt 5.15 中已弃用的 API 已从 Qt 6 中删除。该检查会发现这些 API,并根据 API 来决定是否提供一个替换。

qt6-header-fixes。从Qt 5到 Qt 6,一些头文件被移动了。这个检查将用 Qt 6 的路径替换过时的路径。

qt6-qhash-signature。这项检查纠正了 qHash、qHashBits、qHashRange 和 qHashRangeCommutative 的签名。

qt6-fwd-fixes。该检查警告 <QtCoreqcontainerfwd.h> 中存在的前向声明。如果 <QtCoreqcontainerfwd.h> 中还没有包含前向声明,则会被删除,取而代之的是 <QtCoreqcontainerfwd.h>。

missing-qobject-macro。这个检查可以找到没有 Q_OBJECT 宏的 QObject 派生类。

如果要使用所有专门用于 Qt 6 移植的 Clazy 检查,用户需要拥有 Qt Creator 14.4.1 或以上版本。在 Qt Creator 中打开项目后,用户需要在分析过程中选择要运行的 Clazy 检查。另外,在 Qt Creator 中,修复程序之间的冲突不会被警告,因此要注意当应用与同一行上发生的不同检查相关的修复程序。

个人建站、企业建站,域名注册、小程序、云服务器、物理主机等业务,咨询蓝队云客服微信:landui507

未经允许不得转载:云技术 » Qt推出Clazy框架帮助项目从Qt 5移植到Qt 6

赞 (0)